Log in

Spirit pip3 install

  • 5
  • 15 Dec '15

Hi,

There is a problem when installing spirit with pip3:

Running setup.py (path:/tmp/pip-build-wid6g14v/unicode-slugify/setup.py) egg_info for package unicode-slugify
Traceback (most recent call last):
File "<string>", line 17, in <module>
File "/tmp/pip-build-wid6g14v/unicode-slugify/setup.py", line 7, in <module>
long_description=open('README.md').read(),
File "/usr/lib/python3.4/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 361: ordinal not in range(128)
Complete output from command python setup.py egg_info:
Traceback (most recent call last):

File "<string>", line 17, in <module>

File "/tmp/pip-build-wid6g14v/unicode-slugify/setup.py", line 7, in <module>

long_description=open('README.md').read(),

File "/usr/lib/python3.4/encodings/ascii.py", line 26, in decode

return codecs.ascii_decode(input, self.errors)[0]

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 361: ordinal not in range(128)


Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-wid6g14v/unicode-slugify
Exception information:
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 122, in main
status = self.run(options, args)
File "/usr/lib/python3/dist-packages/pip/commands/install.py", line 290, in run
requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
File "/usr/lib/python3/dist-packages/pip/req.py", line 1230, in prepare_files
req_to_install.run_egg_info()
File "/usr/lib/python3/dist-packages/pip/req.py", line 326, in run_egg_info
command_desc='python setup.py egg_info')
File "/usr/lib/python3/dist-packages/pip/util.py", line 716, in call_subprocess
% (command_desc, proc.returncode, cwd))
pip.exceptions.InstallationError: Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-wid6g14v/unicode-slugify

When i'm using pip every thing work just fine

Thanks

nitelyEsteban Castro Borsani
  • 15 Dec '15

It seems to be a issue in unicode-slugify and it is reported here

  • 2
  • 15 Dec '15

Should I use " Django version 1.9 and python 3.5 "?

Thanks for your reply

nitelyEsteban Castro Borsani
  • 15 Dec '15

Spirit only supports Django 1.8 ATM.

  • 15 Dec '15

Ok thanks :-)

Reply