Log in

Too much requests, wait 10 sec.

  • 1
  • 16 May '16

HI, I'm testing this Q&A plugin within the DjangoCMS.
So far I was able to "merge" this to together, but now, when I try to create a new topic locally and click on Publich a new red marked info occurs with the text "Too much requests, wait 10 sec.". I'm new in django, so maybe this is the matter of some settings in the MIDDLEWARE_CLASSES or similar, but maybe you can help me? :)

Thanks.

With regards,
Konrad

ENV: Centos 6.7 via vagrant, python 3.4, django 1.8

nitelyEsteban Castro Borsani
  • 16 May '16

Did you clone the repo? are you in master? see this

Just switch to a stable branch (v0.x.x) or install through pip.

  • 17 May '16

Hi, I didn't clone the repo, instead I installed this via pip
pip install -e git+https://github.com/nitely/Spirit#egg=django-spirit, I hope it is using the master :)

I will check your link later and let you know if this works

  • 1
  • 17 May '16

According to admin dashboard my version of spirit is 0.4.7. Is that the actually stable version?
Additionally, today after I reload my vagrant it works once, after that I couldn't create any new theme or comment.
Maybe is this some kind of cache?

nitelyEsteban Castro Borsani
  • 17 May '16

When I said pip, I meant from Pypi. That is indeed using master, which is the development branch, it is not stable.

To install from pypi you can do pip install django-spirit

You should first remove your current installation.

  • 23 May '16

ok, I've tried to install it once again via pip install django-spirit, but right know I've got some problems with the pillow

THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
Pillow==3.1.0 from https://pypi.python.org/packages/9c/99/f7fbf76e39cab684161243d6ce6c757ca9a06768d117bc0be4e9fa130d7e/Pillow-3.1.0.tar.gz#md5=506b65d4353cd76b480decb961fa753a (from django-spirit):
Expected md5 506b65d4353cd76b480decb961fa753a
Got 8bab85f0d9ef360df50145afd9dabfd9

Did you notice such problem?

nitelyEsteban Castro Borsani
  • 2
  • 23 May '16

Try this:

pip install --no-cache-dir django-spirit

Or since git seems to work for you:

pip install -e git+https://github.com/nitely/Spirit/tree/v0.4.x

btw, Spirit 0.4.7 is the stable version. But master/dev is also in 0.4.7 coz I forgot to update the version to 0.4.8-pre.

  • 23 May '16

thanks @nitely --no-cache-dir parameter did his work. Just tested it now and all seem to work.

This comment was deleted.
This comment was deleted.
Reply